summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 20:11:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 20:22:46 +0100
commit0d3bf7c58533d0c2edd897480fdad34bc507fdc3 (patch)
treeedaaf0957dc2e192521cda0db5008b1c240180a2 /dev-python/fitsio/fitsio-1.2.1.ebuild
parentdev-python/fitsio: Remove old (diff)
downloadgentoo-0d3bf7c58533d0c2edd897480fdad34bc507fdc3.tar.gz
gentoo-0d3bf7c58533d0c2edd897480fdad34bc507fdc3.tar.bz2
gentoo-0d3bf7c58533d0c2edd897480fdad34bc507fdc3.zip
dev-python/fitsio: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fitsio/fitsio-1.2.1.ebuild')
-rw-r--r--dev-python/fitsio/fitsio-1.2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/fitsio/fitsio-1.2.1.ebuild b/dev-python/fitsio/fitsio-1.2.1.ebuild
new file mode 100644
index 000000000000..543a39335611
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="
+ https://github.com/esheldon/fitsio/
+ https://pypi.org/project/fitsio/
+"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+export FITSIO_USE_SYSTEM_FITSIO=1
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}