summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:06:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:25:24 +0300
commitadfbdb86d437fc5df163c806d4e9859f45eedd35 (patch)
tree38e2b764374dfb53e2299cea982bf77d4fdd2369 /dev-python/fitsio
parentdev-python/sphinx-autodoc-typehints: add 1.19.4 (diff)
downloadgentoo-adfbdb86d437fc5df163c806d4e9859f45eedd35.tar.gz
gentoo-adfbdb86d437fc5df163c806d4e9859f45eedd35.tar.bz2
gentoo-adfbdb86d437fc5df163c806d4e9859f45eedd35.zip
dev-python/fitsio: add 1.1.8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fitsio')
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/fitsio-1.1.8.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index 218062451e1a..12d49b8c982b 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1 +1,2 @@
DIST fitsio-1.1.7.gh.tar.gz 5052055 BLAKE2B be9c632dcdd08325c5abb2cb9ed9eee6476b27ef2e7197298b269156346ecb72afc9f1d1c2e3ade045f69cde3afac5a6bf3fe5ecbce67fdfc1e6ede529ab1b32 SHA512 d6e81de08c38346050fbaa3e2fb51a496e76133bb0b04f20d816b51b7b7bf21ba37a400c3a6a7f966959223545c736ca6245427457154a4b5976b5a997e9cfcc
+DIST fitsio-1.1.8.gh.tar.gz 5052021 BLAKE2B fd54450ccce61a502b803e85df92821a0f64c91e6c8a535b09da6d6e68df1a0299ffc57e87b514d46f635d83dbabc15dc67a99d84fc93ca11ba052fab9472210 SHA512 8ff7c675d39c74ae821dde29ebbfaa5686a4c8e4454bf6ec4b7edce2f6a2e026aa3fac584af1647e7913748202c8c8e3d58deba9bf07253e3fe4606fd2b52c93
diff --git a/dev-python/fitsio/fitsio-1.1.8.ebuild b/dev-python/fitsio/fitsio-1.1.8.ebuild
new file mode 100644
index 000000000000..238fbca619fb
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="https://github.com/esheldon/fitsio"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ use_system_fitsio = True
+ EOF
+}
+
+python_test() {
+ cd "${T}" || die
+ "${EPYTHON}" -c "import fitsio; exit(fitsio.test.test())" ||
+ die "Tests failed with ${EPYTHON}"
+}