summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-16 21:53:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-16 21:56:41 +0100
commit10504d2833519a1c358c6fc28417a2800634dc57 (patch)
tree32730ec0e04ddd3f2b32c23922fdfcce668740c3 /dev-python/flake8
parentdev-python/cryptography: Replace virts with cond deps (diff)
downloadgentoo-10504d2833519a1c358c6fc28417a2800634dc57.tar.gz
gentoo-10504d2833519a1c358c6fc28417a2800634dc57.tar.bz2
gentoo-10504d2833519a1c358c6fc28417a2800634dc57.zip
dev-python/flake8: Replace virts with cond deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-3.5.0.ebuild6
-rw-r--r--dev-python/flake8/flake8-3.7.9.ebuild11
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/flake8/flake8-3.5.0.ebuild b/dev-python/flake8/flake8-3.5.0.ebuild
index 13da912b4ca6..e90b92fd28c0 100644
--- a/dev-python/flake8/flake8-3.5.0.ebuild
+++ b/dev-python/flake8/flake8-3.5.0.ebuild
@@ -23,8 +23,10 @@ RDEPEND="
<dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
<dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+ $(python_gen_cond_dep '
+ dev-python/configparser[${PYTHON_USEDEP}]
+ dev-python/enum34[${PYTHON_USEDEP}]
+ ' -2)
"
PDEPEND="
>=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
diff --git a/dev-python/flake8/flake8-3.7.9.ebuild b/dev-python/flake8/flake8-3.7.9.ebuild
index 81df18dff71b..0cc36ad2720e 100644
--- a/dev-python/flake8/flake8-3.7.9.ebuild
+++ b/dev-python/flake8/flake8-3.7.9.ebuild
@@ -24,11 +24,12 @@ RDEPEND="
<dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
>=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]
<dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-typing[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' -2)
- $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' -2)
+ $(python_gen_cond_dep '
+ dev-python/configparser[${PYTHON_USEDEP}]
+ dev-python/enum34[${PYTHON_USEDEP}]
+ dev-python/functools32[${PYTHON_USEDEP}]
+ dev-python/typing[${PYTHON_USEDEP}]
+ ' -2)
!dev-python/pep8[${PYTHON_USEDEP}]
"
PDEPEND="