summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:33:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 11:33:15 +0200
commit4a728b7e6beccd190461eb915d212712cdc90bda (patch)
tree871aabb2f896a5d466859b8c961b198d139cec15 /dev-python/flake8
parentdev-python/pydocstyle: Use PEP517 build (diff)
downloadgentoo-4a728b7e6beccd190461eb915d212712cdc90bda.tar.gz
gentoo-4a728b7e6beccd190461eb915d212712cdc90bda.tar.bz2
gentoo-4a728b7e6beccd190461eb915d212712cdc90bda.zip
dev-python/flake8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.9.2-r1.ebuild36
2 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 5b453f7bdf33..084843824ab3 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1 @@
-DIST flake8-3.9.2.tar.gz 164777 BLAKE2B 1c991296a3e47e4c41f1196fcaf1e7ea059226dfb41657a52fc4f5a9023b54dba21dd99635398e12f37f52f6e498a0a1fb7d87aba0fe7098ebbdfb54dc5598b0 SHA512 618fe1b35070b24395e5d4da9fa1b1f6308abf6f85d8de71b8b553f84d70d9cd7d2a6f616fa1418db9a8b5ad3efab038f4e2d7c6020c0c1bdeb8157e666911fd
DIST flake8-4.0.1.tar.gz 154905 BLAKE2B b93fea36236881da595ae924b056686e0cd35d2466c1858e3ee83262922df8bc38cf5cd40a910980d287d048572dc94eb8d7c8ee4b11ebd1b4a474dfca02490c SHA512 0bdbf0218ce893df1c3e61f51cd3f371a5c72bb49ef78fec39548b1684e49b024e91cf4e3dcea60ba1efc08727985ef485814c372461e062ff4f810da99a1796
diff --git a/dev-python/flake8/flake8-3.9.2-r1.ebuild b/dev-python/flake8/flake8-3.9.2-r1.ebuild
deleted file mode 100644
index ba315d7ed262..000000000000
--- a/dev-python/flake8/flake8-3.9.2-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
-distutils_enable_tests --install pytest