summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 19:13:12 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 19:13:22 +0100
commit19c691f4afe6e388c470750fd00db158afbb6045 (patch)
tree4bbcfb8251dce4ea09d6d423d6e5551677ec37fc /dev-python/flaky
parentdev-python/flake8: Bump (diff)
downloadgentoo-19c691f4afe6e388c470750fd00db158afbb6045.tar.gz
gentoo-19c691f4afe6e388c470750fd00db158afbb6045.tar.bz2
gentoo-19c691f4afe6e388c470750fd00db158afbb6045.zip
dev-python/flaky: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest1
-rw-r--r--dev-python/flaky/flaky-3.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index fdb457838118..d0dd96098b8a 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -2,3 +2,4 @@ DIST flaky-2.4.0.tar.gz 27157 SHA256 6446e186674db9d67be5e85857b6e98a68a6491d5d3
DIST flaky-2.4.1.tar.gz 27430 SHA256 e8e94450c7c5d56bd30e0634fc6c725936e7585322d60469195dfa416c0ab2ea SHA512 2c4736ee370a9462bed29239a525a8a0296ebbb0abc6f194ac36db1fa6fab78d41c3927f1cd3d5c50649f374406e3203c16f0d2f4e3fac6a458392db110ed0f9 WHIRLPOOL a5665b1ae1e8f82ac96ca07675e719f3c5f29a0347c5c5dc1b1badcfc2454b3fa97e9606299f2b23ef30f61a6342d399eedbafb02931b6f9746af6dcc73f53e2
DIST flaky-3.0.1.tar.gz 21683 SHA256 9004f24832130835a89c1d767b1353f867b1e6aae434cde13749485d377a515e SHA512 4774d53cfc4b32f6555a00605c4ccb776811e04baf1de3a96dcb4029eefe83d3f2534f97f8021a0bf2fadf3bb041a863833dc4ef08c782fe979ac52cd4e9a1c6 WHIRLPOOL a32734fd09b88e9889062574bdf6c1c4f179ecbd7381e8964183ada06a53c0669db81edf16f0096cd4a4a7c1df49917ffd97387a8f0c7c92587b0f0697fd0d6b
DIST flaky-3.0.3.tar.gz 29055 SHA256 24da4483ff313171e5ecbc341c50b8b7fb481850259c44628e2c90f726407770 SHA512 b8f7b858281a9dba6deaed3f5616945a57855165a9ad20520a0c6e514e93d2a73cd66cb5597482d8845d65ee30e0fd62cd5c6e8d7e111e8d5688d27b41729e5e WHIRLPOOL df6848fefbbeb5a18a64d225b1359dfb61dd3469e257d87103095ab8f3ebcbe3b1c318f82b48e9aa50d906df6007e7f89d5f8dea8d2927602b51d543b50af6f7
+DIST flaky-3.1.0.tar.gz 29063 SHA256 8168823da71a415a8fa437807e719b4dc9337780da72d4459112f3a366ec31f5 SHA512 ac97f829ecf1e8e3b48571b0c895de149ee2fbe92c3cfd9e53e8521684a16e8d32c7f2cda2b92dd504b65127b67a8eaf1e91fb54d0db0a5d61be912b5fa0e824 WHIRLPOOL 194ede5eaf61e4180247f44d213508eeca8b9a0b3aee9f189122d7762dbd8b135b9e79e3752586b37624004ce899b4ea92d6bb085cc0674c7721985c46aa8b54
diff --git a/dev-python/flaky/flaky-3.1.0.ebuild b/dev-python/flaky/flaky-3.1.0.ebuild
new file mode 100644
index 000000000000..1dd7db044ad0
--- /dev/null
+++ b/dev-python/flaky/flaky-3.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.python.org/pypi/flaky https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}