summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-04 14:19:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-04 15:15:15 +0100
commit9284e41dd85adc73c472aac4c4e8e8974def33ed (patch)
treee5a7c2924d42051f3e6655e77f6e0a33bde18fe3 /dev-python/flaky
parentdev-python/genty: New package, ebuild written by me (diff)
downloadgentoo-9284e41dd85adc73c472aac4c4e8e8974def33ed.tar.gz
gentoo-9284e41dd85adc73c472aac4c4e8e8974def33ed.tar.bz2
gentoo-9284e41dd85adc73c472aac4c4e8e8974def33ed.zip
dev-python/flaky: New package, ebuild written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest1
-rw-r--r--dev-python/flaky/flaky-2.4.0.ebuild39
-rw-r--r--dev-python/flaky/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
new file mode 100644
index 000000000000..1dbc2117d5cb
--- /dev/null
+++ b/dev-python/flaky/Manifest
@@ -0,0 +1 @@
+DIST flaky-2.4.0.tar.gz 27157 SHA256 6446e186674db9d67be5e85857b6e98a68a6491d5d307447d9a1a6721aca9fad SHA512 e3f51dab94a2e2140714f15ae088113c2e5cb65f58d38d5ae20b91c567c207568403c1267edeaf9f0f8c6bec7b03ebb0c02178cca30f3dd3a16aa4d099ca8153 WHIRLPOOL 20571c64d46ebbb87173a0e6bc859473528270c179c7cde045fded2a98708034f95864a92c137596b936f78e21984ca17ec0670063c470f14d1ce6ce1213c70f
diff --git a/dev-python/flaky/flaky-2.4.0.ebuild b/dev-python/flaky/flaky-2.4.0.ebuild
new file mode 100644
index 000000000000..c802137d75e3
--- /dev/null
+++ b/dev-python/flaky/flaky-2.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.python.org/pypi/flaky https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+# https://github.com/box/flaky/issues/72
+RESTRICT=test
+
+python_test() {
+ nosetests --with-flaky --exclude="pytest|test_nose_options_example" test/ || die
+ py.test -k 'example and not nose and not options' --doctest-modules test/·||·die
+ py.test -p no:flaky test/test_flaky_pytest_plugin.py·||·die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose_options_example.py ·||·die
+ py.test --force-flaky --max-runs 2 test/test_pytest_options_example.py ||·die
+}
diff --git a/dev-python/flaky/metadata.xml b/dev-python/flaky/metadata.xml
new file mode 100644
index 000000000000..c1661663322e
--- /dev/null
+++ b/dev-python/flaky/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>