summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 14:06:05 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 14:06:05 +0100
commit6933477b5ce8f80e79f931238ceb2d8f07e8f19b (patch)
tree815d68b5a780da8f36f53ad97022442394a0fda9 /dev-python/flask-admin
parentdev-python/cx_Freeze: Remove old (diff)
downloadgentoo-6933477b5ce8f80e79f931238ceb2d8f07e8f19b.tar.gz
gentoo-6933477b5ce8f80e79f931238ceb2d8f07e8f19b.tar.bz2
gentoo-6933477b5ce8f80e79f931238ceb2d8f07e8f19b.zip
dev-python/flask-admin: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-admin')
-rw-r--r--dev-python/flask-admin/Manifest1
-rw-r--r--dev-python/flask-admin/flask-admin-1.5.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/flask-admin/Manifest b/dev-python/flask-admin/Manifest
index 069d93023b70..6482655fbff2 100644
--- a/dev-python/flask-admin/Manifest
+++ b/dev-python/flask-admin/Manifest
@@ -1,2 +1 @@
-DIST Flask-Admin-1.5.0.tar.gz 1598074 BLAKE2B a7ca1fab32621cacfcf691f779e88e134369be82f1904db02f72cd51fbbdfecb22b9da06800a9cfae99336ed2807914a6420248c43775c9ec37d65ce242ce17c SHA512 dbf5b97f27228eb000fd1298f4da8d4824196856e4ba9e2d8cbae6e562794ec2d1a998b382efaa84ec4fd7a74ae589a739c52e117efebfb171f19bc16e7350e7
DIST Flask-Admin-1.5.1.tar.gz 1587527 BLAKE2B e734284d3adb7380b71df3718910977c49f76c7e561991c969b8e85952cd3963ede0e1e039c8dcb7c512c00851f1968a9c6e011ad1a064dd8fe4d00390581c31 SHA512 00e31f126048321114e422fda4a0ec84b5caa1a0c03afa17fc6a7078a3f99f843c2688b07462bae283533d52a575935dbab2ce6b731b1d1c3a1e93f315e37de3
diff --git a/dev-python/flask-admin/flask-admin-1.5.0.ebuild b/dev-python/flask-admin/flask-admin-1.5.0.ebuild
deleted file mode 100644
index 12d9c34a52fd..000000000000
--- a/dev-python/flask-admin/flask-admin-1.5.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-#RESTRICT="test" # we're still missing some of the dependencies
-
-MY_PN="Flask-Admin"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple and extensible admin interface framework for Flask"
-HOMEPAGE="https://pypi.org/project/Flask-Admin/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/flask-0.7[${PYTHON_USEDEP}]
- dev-python/wtforms[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-wtf[${PYTHON_USEDEP}]
- dev-python/peewee[${PYTHON_USEDEP}]
- dev-python/wtf-peewee[${PYTHON_USEDEP}]
- dev-python/flask-pymongo[${PYTHON_USEDEP}]
- dev-python/flask-mongoengine[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/flask-babelex[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
- dev-python/geoalchemy2[${PYTHON_USEDEP}]
- >=dev-python/pillow-2.9[${PYTHON_USEDEP},jpeg(+)]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed \
- -e 's:find_packages():find_packages(exclude=["*.examples", "*.examples.*", "examples.*", "examples"]):g' \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}