summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViktar Patotski (aka xp-vit) <xp.vit.blr@gmail.com>2020-05-02 16:08:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 08:35:40 +0200
commit4bf0c56df14ffa10dc6583b55864428720272e65 (patch)
treec0dc99a92d80cb2df5e771dddf2f667661b30ff8 /dev-python/flask-babelex/flask-babelex-0.9.4.ebuild
parentx11-misc/xdg-utils: Make a 1.1.3_p20200220 snap (diff)
downloadgentoo-4bf0c56df14ffa10dc6583b55864428720272e65.tar.gz
gentoo-4bf0c56df14ffa10dc6583b55864428720272e65.tar.bz2
gentoo-4bf0c56df14ffa10dc6583b55864428720272e65.zip
dev-python/flask-babelex: version bump to 0.9.4
Bump to 0.9.4. This also fixes compatobility with dev-python/werkzeug-1.0.0+. Closes: https://bugs.gentoo.org/720466 Closes: https://bugs.gentoo.org/708714 Signed-off-by: Viktar Patotski <xp.vit.blr@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15611 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-babelex/flask-babelex-0.9.4.ebuild')
-rw-r--r--dev-python/flask-babelex/flask-babelex-0.9.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild b/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild
new file mode 100644
index 000000000000..75210c43206e
--- /dev/null
+++ b/dev-python/flask-babelex/flask-babelex-0.9.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PN="Flask-BabelEx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Adds i18n/l10n support to Flask applications"
+HOMEPAGE="https://github.com/mrjoes/flask-babelex https://pypi.org/project/Flask-BabelEx/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ >=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+distutils_enable_sphinx docs \
+ dev-python/flask-sphinx-themes
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.3-tests-fix.patch" )
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" tests.py || die "Testing failed with ${EPYTHON}"
+}