summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-23 10:31:28 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-24 11:06:32 +0800
commit1b501b7197caf2844084488cbecdf6b66df5fad4 (patch)
treecd74b91fd5c5bbcd32c0133bf10e11ebd9f4259a /dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
parentapp-text/linuxdoc-tools: fix LICENSE (diff)
downloadgentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.tar.gz
gentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.tar.bz2
gentoo-1b501b7197caf2844084488cbecdf6b66df5fad4.zip
dev-python/flask-bootstrap: bump to 3.3.6.0
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1523 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild')
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
new file mode 100644
index 000000000000..5dc2327e3279
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}