summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-16 02:07:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-16 10:27:53 +0100
commit97a4e594d709be0e1bb282ff6563c26c7fb770a6 (patch)
tree8eb991cf15f520c30f004d55d14da70150706702 /dev-python/flask-bootstrap
parentdev-python/minidb: update HOMEPAGE (diff)
downloadgentoo-97a4e594d709be0e1bb282ff6563c26c7fb770a6.tar.gz
gentoo-97a4e594d709be0e1bb282ff6563c26c7fb770a6.tar.bz2
gentoo-97a4e594d709be0e1bb282ff6563c26c7fb770a6.zip
dev-python/flask-bootstrap: bump to 3.3.7.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3497
Diffstat (limited to 'dev-python/flask-bootstrap')
-rw-r--r--dev-python/flask-bootstrap/Manifest1
-rw-r--r--dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/flask-bootstrap/Manifest b/dev-python/flask-bootstrap/Manifest
index 967a15998112..a080ce68b4a6 100644
--- a/dev-python/flask-bootstrap/Manifest
+++ b/dev-python/flask-bootstrap/Manifest
@@ -1,2 +1,3 @@
DIST flask-bootstrap-3.3.6.0.tar.gz 489779 SHA256 b7e215fbd570940a5a29fa08d41ee5958b616947f39f93cbd9d0ae3e5ed6d56a SHA512 4cf08a6fd75185fdf5c89783cf8610d74835bf9dc07bd83b36819147bd40cf0e10d20f563a5fc5b8e799e2b87f1e80ad896c76930ca1bc72f74a94818ac708c8 WHIRLPOOL 2963b38b7f076e5289e75ff439eb9facf3b025a548b907cd4a8166c833f164aa6b631a4ffbcad95b0d90c384bb0ccb95523f7c244334232a6d8ce6f43fb94266
DIST flask-bootstrap-3.3.7.0.tar.gz 490438 SHA256 c526afd60c8d56391d2a728706470aa5f789ea6bc739c01613973652b1932f78 SHA512 0c7950d633d88f2e71eab444760229efde324b5169bc774215db4a5cd816d4b8eee8b5d55a68921330b2018d4ae57aafefa6e66cefa0ee822260103cf42143e6 WHIRLPOOL 698d5aee5c188349d6f00a0a9acc1fc8bb62b0ef707e4de46d6be1c788d1a578f64319f1936d47d9e2f69825a70ba15743cede32aa08ac8dda37d44ecdbb21e6
+DIST flask-bootstrap-3.3.7.1.tar.gz 490821 SHA256 b5c188cebd80eabe94f3ea2189429a9070cdbf102d2ae31aa007883d86d25f16 SHA512 010c71f69a95cb51afb449d1b43cb345ad23815ea89b368281f721a2af13cf2c143d67b586114898450d8e7fec413f45ff042cfca3dc1183cb0f50566e39fdc3 WHIRLPOOL a5c2991d391252909027cc67cafd0b4ddc98247c3762969ca7da5de6530911c07bbed73ee6dd836f70632acf5d2b211df0e76b4ed7fb7b759878bb2b663faf5c
diff --git a/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
new file mode 100644
index 000000000000..05c24efd664a
--- /dev/null
+++ b/dev-python/flask-bootstrap/flask-bootstrap-3.3.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An extension that includes Bootstrap in your project, without boilerplate code"
+HOMEPAGE="https://pythonhosted.org/Flask-Bootstrap/"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/flask-bootstrap/pull/134
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask-appconfig[${PYTHON_USEDEP}]
+ dev-python/flask-debug[${PYTHON_USEDEP}]
+ dev-python/flask-nav[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test -k "not test_versions_match" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}