summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-11-17 23:46:51 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-11-17 23:46:51 -0500
commitc7b7b0913683f19e26a32b52a0e662080a179c4a (patch)
tree5ac98f52f25b6b6eb6e0bb3248b15597df47b70d /dev-python/flask-compress
parentapp-metrics/process-exporter: Bump to version 0.7.5 (diff)
downloadgentoo-c7b7b0913683f19e26a32b52a0e662080a179c4a.tar.gz
gentoo-c7b7b0913683f19e26a32b52a0e662080a179c4a.tar.bz2
gentoo-c7b7b0913683f19e26a32b52a0e662080a179c4a.zip
dev-python/flask-compress: Bump to 1.8.0
The test flag has been dropped, negating the need for RESTRICT="!test? ( test )". Also swapped around maintainers to make myself primary as originally intended. Closes: https://bugs.gentoo.org/754699 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/flask-compress')
-rw-r--r--dev-python/flask-compress/Manifest1
-rw-r--r--dev-python/flask-compress/flask-compress-1.8.0.ebuild27
-rw-r--r--dev-python/flask-compress/metadata.xml8
3 files changed, 32 insertions, 4 deletions
diff --git a/dev-python/flask-compress/Manifest b/dev-python/flask-compress/Manifest
index ee9d97ab0a94..aa7deadfb61a 100644
--- a/dev-python/flask-compress/Manifest
+++ b/dev-python/flask-compress/Manifest
@@ -1 +1,2 @@
DIST Flask-Compress-1.5.0.tar.gz 6473 BLAKE2B eba68544018d587a7651c07739ac14218ff9918031fee740893245816daa7494d4998cf60b533971ba8dc0c7c9e3d1e1c14ee746d9e29deab70b30478a3c4eae SHA512 fe2d1dfef8be8d04b78a2938dd52a1f6068e6c35741f593fbb0d3d050b789b8d70188d683f7028b92a180653afda0566bda29b82475b20444f6563c8620ff1ec
+DIST Flask-Compress-1.8.0.tar.gz 10182 BLAKE2B ff292503dd0a141ffb3d49e57f62755c59244129e53268f97d0ab5bdf4644108d9eea5567982fbb000afe54d7a418751f5b8ecb685b3e42c25413e7740d03004 SHA512 9bdc45b6d189e8b896a781dc48b761ac99a551a32bdaa9695556e7dabfd76f7ef98249397a31492e629ea35d82c5104d99b5803b9ecf9b2637cc802a87939f1c
diff --git a/dev-python/flask-compress/flask-compress-1.8.0.ebuild b/dev-python/flask-compress/flask-compress-1.8.0.ebuild
new file mode 100644
index 000000000000..9197bdc599fc
--- /dev/null
+++ b/dev-python/flask-compress/flask-compress-1.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Compress"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Compress responses in your Flask app with gzip"
+HOMEPAGE="https://pypi.org/project/Flask-Compress"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/flask-compress/metadata.xml b/dev-python/flask-compress/metadata.xml
index 05b10e7385a6..7a15dcf1edb8 100644
--- a/dev-python/flask-compress/metadata.xml
+++ b/dev-python/flask-compress/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
<maintainer type="person">
<email>titanofold@gentoo.org</email>
<name>Aaron W. Swenson</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">Flask-Gravatar</remote-id>