summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-25 07:43:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-25 10:28:08 +0200
commita2707a0976b6e50e8ab0d178425aa7ceae7f4bbf (patch)
tree398ea4afba816eb54787fc7a8de732d701095b93 /dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild
parentapp-admin/awscli: Bump to 1.26.0 (diff)
downloadgentoo-a2707a0976b6e50e8ab0d178425aa7ceae7f4bbf.tar.gz
gentoo-a2707a0976b6e50e8ab0d178425aa7ceae7f4bbf.tar.bz2
gentoo-a2707a0976b6e50e8ab0d178425aa7ceae7f4bbf.zip
dev-python/flask-htmlmin: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild')
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild
new file mode 100644
index 000000000000..a19920f25153
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P="Flask-HTMLmin-${PV}"
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="
+ https://github.com/hamidfzm/Flask-HTMLmin/
+ https://pypi.org/project/Flask-HTMLmin/
+"
+SRC_URI="
+ https://github.com/hamidfzm/Flask-HTMLmin/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/cssmin[${PYTHON_USEDEP}]
+ app-text/htmlmin[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest