summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 09:50:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:26:56 +0200
commit31ff0d9e8cb9203da31d6a08eb57b2716a9c4a57 (patch)
tree5c0f116bd67b3a4e97ddc5279b21dd61dc5b0e76 /dev-python/flask-login
parentdev-python/wrapt: Bump to 1.14.1 (diff)
downloadgentoo-31ff0d9e8cb9203da31d6a08eb57b2716a9c4a57.tar.gz
gentoo-31ff0d9e8cb9203da31d6a08eb57b2716a9c4a57.tar.bz2
gentoo-31ff0d9e8cb9203da31d6a08eb57b2716a9c4a57.zip
dev-python/flask-login: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-login')
-rw-r--r--dev-python/flask-login/Manifest1
-rw-r--r--dev-python/flask-login/flask-login-0.6.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/flask-login/Manifest b/dev-python/flask-login/Manifest
index 22e1532de5fa..0a9dd00a5e68 100644
--- a/dev-python/flask-login/Manifest
+++ b/dev-python/flask-login/Manifest
@@ -1 +1,2 @@
DIST flask-login-0.6.0.gh.tar.gz 47368 BLAKE2B 799591ec0bd538e6cc467a80b3a8891a97ee60bbfcf01eb6ba7be1ab48e7ea9be22e8777801621b39bf089c00d7914f7b045e4e6617e45d623354276ba7e245b SHA512 0766ef5702105bc2cea7082b2b2a9bebed282a9166757adbc91a02c4adcc291d41a3217e8b9566b6bb4778db4a1d2453edb0b7a727c9bff2673833d27b69148e
+DIST flask-login-0.6.1.gh.tar.gz 48215 BLAKE2B eb1fa81aad9bd8cf663b3ea85649f90f39d7a91c4c771e697b0cb7d66c7e4a5994befbaad36a7deba6f5aea27e6f47ff616aa00cd073433851cf8a9248e4b3a3 SHA512 f220e24079923c669d1ce27fdbc7ff8e07e92bc947e2708034cb349176e33ae0adf36ef6c30e8328f592d9a3eb6d0796dc577033f07c33ef0bc48c13a11a942e
diff --git a/dev-python/flask-login/flask-login-0.6.1.ebuild b/dev-python/flask-login/flask-login-0.6.1.ebuild
new file mode 100644
index 000000000000..8ad7a727fcac
--- /dev/null
+++ b/dev-python/flask-login/flask-login-0.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Login session support for Flask"
+HOMEPAGE="
+ https://github.com/maxcountryman/flask-login/
+ https://pypi.org/project/Flask-Login/
+"
+SRC_URI="
+ https://github.com/maxcountryman/flask-login/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-1.0.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}