summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:23 +0200
commit4d81dd951647ffe0346a54303c6b20d4d7277d9b (patch)
tree9580849d66a16a949f5ce7664f5ecc715748d9dc /dev-python/flask-nav
parentdev-python/flask-debug: Remove old (diff)
downloadgentoo-4d81dd951647ffe0346a54303c6b20d4d7277d9b.tar.gz
gentoo-4d81dd951647ffe0346a54303c6b20d4d7277d9b.tar.bz2
gentoo-4d81dd951647ffe0346a54303c6b20d4d7277d9b.zip
dev-python/flask-nav: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-nav')
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/flask-nav/flask-nav-0.6-r1.ebuild b/dev-python/flask-nav/flask-nav-0.6-r1.ebuild
deleted file mode 100644
index d8fdd36f3ced..000000000000
--- a/dev-python/flask-nav/flask-nav-0.6-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create navigation for Flask applications."
-HOMEPAGE="https://pythonhosted.org/flask-nav/"
-# docs are missing from PyPI tarballs
-# https://github.com/mbr/flask-nav/pull/12
-SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/dominate[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/visitor[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/alabaster[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}