summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 09:26:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 09:57:34 +0100
commitabe8a551344ad0fa4ee11e5b527825909b95fa10 (patch)
tree5e56f5de9af727457e2ab072744721eada7f934d /dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
parentdev-vcs/gitg: Bump to v41 (diff)
downloadgentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.tar.gz
gentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.tar.bz2
gentoo-abe8a551344ad0fa4ee11e5b527825909b95fa10.zip
dev-python/flask-paginate: Bump to 2021.12.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
new file mode 100644
index 000000000000..49d2d8c73c6e
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}