summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-23 14:20:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-23 14:34:47 +0200
commit2fd7c81f13c52a5aab365d5ecd075c5e439cc1fb (patch)
treeda18ca38706024fd8b40f7bfe49b2a6864519531 /dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
parentdev-python/lark: Bump to 1.1.8 (diff)
downloadgentoo-2fd7c81f13c52a5aab365d5ecd075c5e439cc1fb.tar.gz
gentoo-2fd7c81f13c52a5aab365d5ecd075c5e439cc1fb.tar.bz2
gentoo-2fd7c81f13c52a5aab365d5ecd075c5e439cc1fb.zip
dev-python/flask-paginate: Bump to 2023.10.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild b/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
new file mode 100644
index 000000000000..545297259bb7
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="
+ https://flask-paginate.readthedocs.io/
+ https://github.com/lixxu/flask-paginate/
+ https://pypi.org/project/flask-paginate/
+"
+SRC_URI="
+ https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}