summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-16 14:45:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-16 15:04:22 +0000
commitc58fc2f6793326028730798ab6b42d828430fa4d (patch)
treea5f64de87a98ab2f3eecae36659154a52fdbaca3 /dev-python/flask-restful/flask-restful-0.3.6.ebuild
parentsys-cluster/neutron: 10.0.3 and 9.4.1 stable amd64 and x86 with cleanup (diff)
downloadgentoo-c58fc2f6793326028730798ab6b42d828430fa4d.tar.gz
gentoo-c58fc2f6793326028730798ab6b42d828430fa4d.tar.bz2
gentoo-c58fc2f6793326028730798ab6b42d828430fa4d.zip
dev-python/flask-restful: Bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/flask-restful/flask-restful-0.3.6.ebuild')
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.6.ebuild b/dev-python/flask-restful/flask-restful-0.3.6.ebuild
new file mode 100644
index 000000000000..a55d4e3709b3
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="http://flask-restful.readthedocs.org/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}