summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:38 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:38 +0100
commit640eaf4dfcc62b1e9ffc88e7d31de690e737e032 (patch)
treeae3e513514d45a838693f542fac76bfa9d3373e5 /dev-python/flask-script
parentdev-python/flask-nav: Remove old (diff)
downloadgentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.tar.gz
gentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.tar.bz2
gentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.zip
dev-python/flask-script: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/Manifest1
-rw-r--r--dev-python/flask-script/flask-script-2.0.5-r1.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/flask-script/Manifest b/dev-python/flask-script/Manifest
index 426bedb221c9..31afe56414b4 100644
--- a/dev-python/flask-script/Manifest
+++ b/dev-python/flask-script/Manifest
@@ -1,2 +1 @@
-DIST Flask-Script-2.0.5.tar.gz 42580 BLAKE2B e614890fcf57c4122098a6181171d288c83bc80611ab1d240a41d57de522079fa1be68a679fd27a84fe36a843e5ddf8aa7b29eded66761e75b4b2e9771468074 SHA512 257b724c05dde79c99b028c7fa1980b700f273010de82fa9f1bb090b23519297d8bad87e436fa88a63feabfcd8908041d4a5ad9a673e08f4ed15e97310f16fbb
DIST Flask-Script-2.0.6.tar.gz 43146 BLAKE2B 146a65fce432063e67e5b6221a0c2437f2a8df1e2b72a5e14fb382dc51ef3f0755e4d8a0a67831c6c2c61d07acc332e8c87b7c9df3443a9f22aa2eeb580c4086 SHA512 03c51213be8e2b86f1f4450565cf4d7e3d9d7257ac017bd53830be57620d581f43bcfe959ef7b621af722c688c56495229aad3dd9654c8a8a5905db0105275fc
diff --git a/dev-python/flask-script/flask-script-2.0.5-r1.ebuild b/dev-python/flask-script/flask-script-2.0.5-r1.ebuild
deleted file mode 100644
index 7e2b014394a8..000000000000
--- a/dev-python/flask-script/flask-script-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts"
-HOMEPAGE="https://flask-script.readthedocs.io/en/latest/
- https://flask-script.readthedocs.io/en/latest/
- https://pypi.org/project/Flask-Script/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}