summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-05-20 12:53:08 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-05-20 12:53:08 -0400
commit002e2a6b71f81f2828cb906d5ebd0386da236de9 (patch)
tree7214aff9f24013160b0138de10263670f1f0b3cd /dev-python/flask-security
parentapp-misc/vifm: Swotch to HTTPS (diff)
downloadgentoo-002e2a6b71f81f2828cb906d5ebd0386da236de9.tar.gz
gentoo-002e2a6b71f81f2828cb906d5ebd0386da236de9.tar.bz2
gentoo-002e2a6b71f81f2828cb906d5ebd0386da236de9.zip
dev-python/flask-security: Fix {R,}DEPEND
Closes: https://bugs.gentoo.org/656060 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/flask-security-3.0.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/flask-security/flask-security-3.0.0.ebuild b/dev-python/flask-security/flask-security-3.0.0.ebuild
index 569f75e8202c..a816005949bc 100644
--- a/dev-python/flask-security/flask-security-3.0.0.ebuild
+++ b/dev-python/flask-security/flask-security-3.0.0.ebuild
@@ -20,14 +20,18 @@ IUSE="test"
# tests are foobar
RESTRICT="test"
-RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/flask-0.11[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.3.0[${PYTHON_USEDEP}]
>=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
+ >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.13.1[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7[${PYTHON_USEDEP}]
+"
+
DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]