summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 10:26:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 10:52:33 +0100
commit45eb6d5268c9aa9854853f59b813a012397ae816 (patch)
treef4b400f9edecbdcb42a09130575017cdb4c383d1 /dev-python/flask-security
parentdev-python/construct: Bump to 2.10.57 (diff)
downloadgentoo-45eb6d5268c9aa9854853f59b813a012397ae816.tar.gz
gentoo-45eb6d5268c9aa9854853f59b813a012397ae816.tar.bz2
gentoo-45eb6d5268c9aa9854853f59b813a012397ae816.zip
dev-python/flask-security: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/Manifest1
-rw-r--r--dev-python/flask-security/files/flask-security-4.0.0-test-install.patch25
-rw-r--r--dev-python/flask-security/flask-security-4.0.0.ebuild65
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index 03260ea67c0d..f3cb59c61c49 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1,2 +1,3 @@
DIST flask-security-3.4.4.gh.tar.gz 348525 BLAKE2B 77a851c2549be9ce8612e3b186ad2d83d272b277f286885da491f3f0fe99e8836d145749ae137f1e75625c34b2214270ba4d24f1bfaa514012064dd38f083230 SHA512 1c1a4f079199704d7a2a4e11351cd199e3a790f5d0c7f68b240c299e83b129227fac4ca00caf45401efbf14520c1d65d3b710b85e8f53b495283b94a164f97a2
DIST flask-security-3.4.5.gh.tar.gz 348928 BLAKE2B 9890227e9775c4a28fc364affb0bf767407463d514f6dc3cd359dd8a026e8325d943a547f294f6363a276f9e7d97336c526dd45f4549c7cfaff2d6ef9ef0316a SHA512 f9ac7f46b2e1ab7dbb44ba925b01e16304e8f8d6d5d56f4e558d07b80dfffa59f04c2597e17c00a7d7ae11be3a97c78ccf8d79993b7451be4a7f75f85bc89f6f
+DIST flask-security-4.0.0.gh.tar.gz 381592 BLAKE2B 62f8ceb5b6912839ad69a9f26793a831304f0d03cd40c73bd7c6701421d22955bec1e43713b2e07004ff9686591370378d9ff6e2e61e6bdc9a6472f18b28bfad SHA512 1d616121d0220bdef6081f4feb2c56b6feb346609548ad74c7bbbb60f4d65e9b3ec92a35fa9e077c35db9ab398d921461450594185956d05d5dda063fe972b72
diff --git a/dev-python/flask-security/files/flask-security-4.0.0-test-install.patch b/dev-python/flask-security/files/flask-security-4.0.0-test-install.patch
new file mode 100644
index 000000000000..8e78cf7b1116
--- /dev/null
+++ b/dev-python/flask-security/files/flask-security-4.0.0-test-install.patch
@@ -0,0 +1,25 @@
+From 09fb542d472c863495a88c9cd73d692d86e86c22 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 26 Jan 2021 10:50:08 +0100
+Subject: [PATCH] Do not install global-scope 'tests' package
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 1d832b7..7abc0f3 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,7 +19,7 @@ install_requires = [
+ "passlib>=1.7.2",
+ ]
+
+-packages = find_packages()
++packages = find_packages(exclude=['tests'])
+
+ setup(
+ name="Flask-Security-Too",
+--
+2.30.0
+
diff --git a/dev-python/flask-security/flask-security-4.0.0.ebuild b/dev-python/flask-security/flask-security-4.0.0.ebuild
new file mode 100644
index 000000000000..7260574a0d43
--- /dev/null
+++ b/dev-python/flask-security/flask-security-4.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="
+ https://github.com/Flask-Middleware/flask-security/
+ https://pypi.org/project/Flask-Security-Too/"
+SRC_URI="
+ https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
+ >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
+ >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
+ >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/flask-security-4.0.0-test-install.patch
+)
+
+src_prepare() {
+ sed -i -e 's@--cache-clear@-p no:httpbin@' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ esetup.py compile_catalog
+}