summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 08:49:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:07:06 +0200
commit9b93f09b20a459bd3a23ebc36410dfe29da3928e (patch)
treea15c88c055fcbefc3b0702968335935acb516679 /dev-python/flask-security
parentdev-python/flask-wtf: Port to py3.9 (diff)
downloadgentoo-9b93f09b20a459bd3a23ebc36410dfe29da3928e.tar.gz
gentoo-9b93f09b20a459bd3a23ebc36410dfe29da3928e.tar.bz2
gentoo-9b93f09b20a459bd3a23ebc36410dfe29da3928e.zip
dev-python/flask-security: Remove pytest-runner dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/flask-security-3.0.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/flask-security/flask-security-3.0.0.ebuild b/dev-python/flask-security/flask-security-3.0.0.ebuild
index 349a0a18f98f..5544516760b3 100644
--- a/dev-python/flask-security/flask-security-3.0.0.ebuild
+++ b/dev-python/flask-security/flask-security-3.0.0.ebuild
@@ -31,8 +31,6 @@ RDEPEND=">=dev-python/flask-0.11[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
@@ -43,6 +41,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
nosetests -v || die "Testing failed with ${EPYTHON}"
}