summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 23:30:23 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 00:35:15 +0100
commitb56d949615cfc31be8ee270e38208dac342d0150 (patch)
treea89416844ebcf0b6bbedd7bc18aff5b072e6aeaa /dev-python/flask-testing/flask-testing-0.6.1.ebuild
parentdev-python/flask-socketio: Clean old up (diff)
downloadgentoo-b56d949615cfc31be8ee270e38208dac342d0150.tar.gz
gentoo-b56d949615cfc31be8ee270e38208dac342d0150.tar.bz2
gentoo-b56d949615cfc31be8ee270e38208dac342d0150.zip
dev-python/flask-testing: Clean old up
Diffstat (limited to 'dev-python/flask-testing/flask-testing-0.6.1.ebuild')
-rw-r--r--dev-python/flask-testing/flask-testing-0.6.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/flask-testing/flask-testing-0.6.1.ebuild b/dev-python/flask-testing/flask-testing-0.6.1.ebuild
deleted file mode 100644
index ef29e92c1d8a..000000000000
--- a/dev-python/flask-testing/flask-testing-0.6.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Testing"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Unit testing for Flask"
-HOMEPAGE="http://pythonhosted.org/Flask-Testing/ https://pypi.python.org/pypi/Flask-Testing/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' 'python2*')"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- local exclude
- if $(python_is_python3); then
- # Twill is not available on python-3
- exclude="-e twill"
- fi
- # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
- nosetests ${exclude} || die "Testing failed with ${EPYTHON}"
-}