summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-25 20:39:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-25 20:42:06 +0200
commit06bca4f96693b3d63c2868d1fb8992aa9090c26e (patch)
tree2787211c2d27cd36ceb3430e82aee560f3046628 /dev-python/flask-wtf/flask-wtf-0.15.1.ebuild
parentdev-python/virtualenv: Remove old (diff)
downloadgentoo-06bca4f96693b3d63c2868d1fb8992aa9090c26e.tar.gz
gentoo-06bca4f96693b3d63c2868d1fb8992aa9090c26e.tar.bz2
gentoo-06bca4f96693b3d63c2868d1fb8992aa9090c26e.zip
dev-python/flask-wtf: Bump to 0.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-wtf/flask-wtf-0.15.1.ebuild')
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.15.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild b/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild
new file mode 100644
index 000000000000..7db390002886
--- /dev/null
+++ b/dev-python/flask-wtf/flask-wtf-0.15.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_PN="Flask-WTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple integration of Flask and WTForms"
+HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-babel[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # tries to access things over the network
+ rm tests/test_recaptcha.py || die
+ distutils-r1_python_prepare_all
+}