summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:09:11 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-20 22:09:57 -0400
commita8e825041163cc1414ef5c820c6e8b6c4d71f9b5 (patch)
tree5f32da1c0e5e2561b25148c9d4b854157505ec5c /dev-python/flask/flask-9999.ebuild
parentdev-python/werkzeug: add python 3.7 support (diff)
downloadgentoo-a8e825041163cc1414ef5c820c6e8b6c4d71f9b5.tar.gz
gentoo-a8e825041163cc1414ef5c820c6e8b6c4d71f9b5.tar.bz2
gentoo-a8e825041163cc1414ef5c820c6e8b6c4d71f9b5.zip
dev-python/flask: bump to 1.0.2
* EAPI 7 * Python 3.7 Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-python/flask/flask-9999.ebuild')
-rw-r--r--dev-python/flask/flask-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 3329ccaa5a94..6b340034d517 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
inherit distutils-r1
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://pypi.org/project/Flask/"
+HOMEPAGE="https://github.com/pallets/flask/"
MY_PN="Flask"
MY_P="${MY_PN}-${PV}"
if [[ ${PV} == *9999* ]]; then
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi
@@ -24,21 +24,29 @@ LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
-RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.14[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- py.test tests || die "Testing failed with ${EPYTHON}"
+ PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
+ py.test -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {