summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-12-09 12:54:52 -0500
committerRick Farina <zerochaos@gentoo.org>2019-12-09 12:54:52 -0500
commit0b27314452e187d6b08affdd077da6f77107fe7b (patch)
treef86cbec92f77b9608ad8c7c5d40d6f5e6b378732 /dev-python/fleep/fleep-9999.ebuild
parentnet-analyzer/gr-fosphor: upstream branch rename (diff)
downloadgentoo-0b27314452e187d6b08affdd077da6f77107fe7b.tar.gz
gentoo-0b27314452e187d6b08affdd077da6f77107fe7b.tar.bz2
gentoo-0b27314452e187d6b08affdd077da6f77107fe7b.zip
dev-python/fleep: import from SpiderX Nest overlay
Package-Manager: Portage-2.3.81, Repoman-2.3.19 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/fleep/fleep-9999.ebuild')
-rw-r--r--dev-python/fleep/fleep-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/fleep/fleep-9999.ebuild b/dev-python/fleep/fleep-9999.ebuild
new file mode 100644
index 000000000000..3482940aec1d
--- /dev/null
+++ b/dev-python/fleep/fleep-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="File format determination library for Python"
+HOMEPAGE="https://github.com/floyernick/fleep-py"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""