summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-12 21:40:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-12 22:08:48 +0300
commit0fb2e03a8d5266f496ba422a503298407021e938 (patch)
tree47908fa53320e1024d7bb9ce7fc0554d71dd9883 /dev-python/fleep
parentdev-python/flatbuffers: enable py3.11 (diff)
downloadgentoo-0fb2e03a8d5266f496ba422a503298407021e938.tar.gz
gentoo-0fb2e03a8d5266f496ba422a503298407021e938.tar.bz2
gentoo-0fb2e03a8d5266f496ba422a503298407021e938.zip
dev-python/fleep: enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fleep')
-rw-r--r--dev-python/fleep/fleep-1.0.1-r1.ebuild7
-rw-r--r--dev-python/fleep/fleep-9999.ebuild6
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/fleep/fleep-1.0.1-r1.ebuild b/dev-python/fleep/fleep-1.0.1-r1.ebuild
index cce82c31af2c..921df3ab8fe3 100644
--- a/dev-python/fleep/fleep-1.0.1-r1.ebuild
+++ b/dev-python/fleep/fleep-1.0.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then
@@ -13,7 +13,6 @@ if [[ ${PV} == 9999 ]]; then
else
# upstream aren't tagging the releases, just as commit title
COMMIT="994bc2c274482d80ab13d89d8f7343eb316d3e44"
- # Note: On next bump, remove gh suffix from SRC_URI - was added just for tests
SRC_URI="https://github.com/floyernick/fleep-py/archive/${COMMIT}.tar.gz
-> ${P}.gh.tar.gz"
S="${WORKDIR}/fleep-py-${COMMIT}"
diff --git a/dev-python/fleep/fleep-9999.ebuild b/dev-python/fleep/fleep-9999.ebuild
index 68f31790d687..3504702d9333 100644
--- a/dev-python/fleep/fleep-9999.ebuild
+++ b/dev-python/fleep/fleep-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then