summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-02-07 09:37:47 +0100
committerHanno Böck <hanno@gentoo.org>2020-02-07 09:37:47 +0100
commit5b7eb9be93dc5e8fa26ec2d4bb07ed13c2167233 (patch)
treec3e4cd6d2875e3802c5ed875caea30ab4b714b76 /dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild
parentdev-python/flufl-bounce: Bump and Python 3.7. (diff)
downloadgentoo-5b7eb9be93dc5e8fa26ec2d4bb07ed13c2167233.tar.gz
gentoo-5b7eb9be93dc5e8fa26ec2d4bb07ed13c2167233.tar.bz2
gentoo-5b7eb9be93dc5e8fa26ec2d4bb07ed13c2167233.zip
dev-python/flufl-i18n: Bump and Python 3.7.
Bug: https://bugs.gentoo.org/705332 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.87, Repoman-2.3.20
Diffstat (limited to 'dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild')
-rw-r--r--dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild b/dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild
new file mode 100644
index 000000000000..e583ee1e34b4
--- /dev/null
+++ b/dev-python/flufl-i18n/flufl-i18n-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="A high level API for Python internationalization."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.i18n"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"