summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-01-05 02:33:02 -0500
committerTim Harder <radhermit@gentoo.org>2018-01-05 05:24:19 -0500
commit029a4bf10ebb826e70cc66fce0c0f9f4eb2fba51 (patch)
treeedc2e5d9c55f21b9255828bd80c0e856cc3c9d6c /dev-python/fonttools/fonttools-3.21.1.ebuild
parentsys-libs/gdbm: Version 1.13-r2 stable for amd64 and x86. (diff)
downloadgentoo-029a4bf10ebb826e70cc66fce0c0f9f4eb2fba51.tar.gz
gentoo-029a4bf10ebb826e70cc66fce0c0f9f4eb2fba51.tar.bz2
gentoo-029a4bf10ebb826e70cc66fce0c0f9f4eb2fba51.zip
dev-python/fonttools: version bump to 3.21.1
Diffstat (limited to 'dev-python/fonttools/fonttools-3.21.1.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-3.21.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-3.21.1.ebuild b/dev-python/fonttools/fonttools-3.21.1.ebuild
new file mode 100644
index 000000000000..1585a70af801
--- /dev/null
+++ b/dev-python/fonttools/fonttools-3.21.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/behdad/fonttools/"
+SRC_URI="https://github.com/behdad/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ touch Tests/svgLib/__init__.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}