summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 21:56:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:11 +0100
commit65b3a27f7975ae3759f4585a7d5e848562124c39 (patch)
tree3bcae69ce14140b82440fde5975cedf0ccbb9b49 /dev-python/fonttools
parentapp-admin/awscli: Bump to 1.22.77 (diff)
downloadgentoo-65b3a27f7975ae3759f4585a7d5e848562124c39.tar.gz
gentoo-65b3a27f7975ae3759f4585a7d5e848562124c39.tar.bz2
gentoo-65b3a27f7975ae3759f4585a7d5e848562124c39.zip
dev-python/fonttools: Bump to 4.31.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.31.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 4f247b7baa60..71bce616400c 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.29.1.tar.gz 2954962 BLAKE2B e78a55e240975e12e9cfd56368eab0d18e104211d8416db833a20208c78f6e5dbce2d24d7338017882f0bd1c3c181c0af0c069025a750cba4e9f41c1b4b2489c SHA512 36f4272be18d19748069289bfb3d3339cf0b16967a12976971f9e2dd56a1e915d3176e0dd9cad08cee69b20f3d6ac1a966365d936bb091b39e23b6c693e28dc9
DIST fonttools-4.30.0.tar.gz 2961097 BLAKE2B 23b592daa16fd215688f149d99258209b819caa843d26c889fb4016aae6d6614a9f87dd13fa1d2aa254fadb5169cf7d57ba02b7b15af79611995148d698ca2ec SHA512 2b4e676f956c3456bf3ca435a7d80e1a0a9f36872ba3a820072d1e13ed5751a8546f424369731afd4ccddc298ec0658bb4384d2e18670b108dd1b3a99fc205f4
+DIST fonttools-4.31.1.tar.gz 2964489 BLAKE2B d1bb7059383785dd527f7276ef876042f81d3e2cc5acc1b69e111b540cf8d35273a0070e6f0602ca438f35e3b83d0a04736cd5c97b1b7669822d1a6b1ad1b487 SHA512 cdf70f376e690ab1edc5e761ba45d1ddd7760c3aefdb5e9b88cc97118edd4ff694789c8b79ece791b4b6a597dcac1abb0eec5f0634f1db0792e5e62a2137282d
diff --git a/dev-python/fonttools/fonttools-4.31.1.ebuild b/dev-python/fonttools/fonttools-4.31.1.ebuild
new file mode 100644
index 000000000000..f0532d0a8742
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.31.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}