summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-06 17:53:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-06 18:45:55 +0100
commit63fc59969042a344be70d431fc68e3eadbe6a90b (patch)
treef889c0bf5ad5b829c0dbd5bba84aa2e10eaad88b /dev-python/fqdn/fqdn-1.5.0-r1.ebuild
parentdev-python/pikepdf: Bump to 2.8.0.post1 (diff)
downloadgentoo-63fc59969042a344be70d431fc68e3eadbe6a90b.tar.gz
gentoo-63fc59969042a344be70d431fc68e3eadbe6a90b.tar.bz2
gentoo-63fc59969042a344be70d431fc68e3eadbe6a90b.zip
dev-python/fqdn: cached-property is needed for py<3.8 only
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fqdn/fqdn-1.5.0-r1.ebuild')
-rw-r--r--dev-python/fqdn/fqdn-1.5.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/fqdn/fqdn-1.5.0-r1.ebuild b/dev-python/fqdn/fqdn-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..deeea469ea8b
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.5.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/guyhughes/fqdn"
+SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs