summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-04 17:07:05 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-04 17:07:19 -0700
commit9965ea6823ee21924b62dbaeeca888929a416cee (patch)
tree3549bd5ad0939c38dba1947098878d45985ac1ff /dev-python/fqdn
parentdev-python/cached-property: add pypy3 target (diff)
downloadgentoo-9965ea6823ee21924b62dbaeeca888929a416cee.tar.gz
gentoo-9965ea6823ee21924b62dbaeeca888929a416cee.tar.bz2
gentoo-9965ea6823ee21924b62dbaeeca888929a416cee.zip
dev-python/fqdn: bump to 1.5.0
upstream switched tests to pytest add py3.9 and pypy targets, drop py3.6 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/fqdn')
-rw-r--r--dev-python/fqdn/Manifest1
-rw-r--r--dev-python/fqdn/fqdn-1.5.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/fqdn/Manifest b/dev-python/fqdn/Manifest
index 04484d55d492..da6d5ab93622 100644
--- a/dev-python/fqdn/Manifest
+++ b/dev-python/fqdn/Manifest
@@ -1,2 +1,3 @@
DIST fqdn-1.2.0.tar.gz 12275 BLAKE2B 0bc862863ee3b196ea08a1f4f50f98dca88e8b81f37d2cb97bd3fd74ef9844157ea7a9f38707047fad17b95fb95c2f0e7ace8ad2c2310171cba6ff43471ae63d SHA512 ddfcfd82860d597075fd2d989d4bb1cd8c1dc79b711da432732bf786032e78b9356e04851a491c5299b336dcde173a66ddae0e23aea59b67c758d997554b494e
DIST fqdn-1.4.0.tar.gz 12962 BLAKE2B 76b7bd7f2ebfd77b2bba04f7e07cdab42f0ff6c7ad5967f52e4c108fc3c3345c88a220b9f0330d998dc5abc53909d5768b1b52e08e48bc1e16009fa39f3afa16 SHA512 e2a67e97bc832526e234bbf19600af2e7eda8f7ede13ba33ec8c736888d19693727eded4b895efd4c88ab2e232db768d42761f44a479e615e13da8ddbf6d03a3
+DIST fqdn-1.5.0.tar.gz 14630 BLAKE2B 021b4e53c42830a5523964961cde9857bea9eb700cd2030331b05006ec4a8b7e05a9f2330748b0d84531526e17d81ade73fb04e65db381417f2d7f618138f09a SHA512 3940955df50bcd0bbd5cae82f148e9a8ef64b6db84dc867fbfbfbdd661fcc42208a7506f931209347f9115722c00e330fc03c5bdd459cb4a98d0df59af48c492
diff --git a/dev-python/fqdn/fqdn-1.5.0.ebuild b/dev-python/fqdn/fqdn-1.5.0.ebuild
new file mode 100644
index 000000000000..9e8e8158b783
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/guyhughes/fqdn"
+SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/cached-property[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs