summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-10-20 18:59:56 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-10-20 18:59:56 +0200
commit84e1235e06adc2273e96a9c1351e74f61aeb8b21 (patch)
tree0263e013ed756a579755a474eb439553f2149079 /dev-python/frozen-flask/frozen-flask-0.13.ebuild
parentdev-python/s3transfer: Bump (diff)
downloadgentoo-84e1235e06adc2273e96a9c1351e74f61aeb8b21.tar.gz
gentoo-84e1235e06adc2273e96a9c1351e74f61aeb8b21.tar.bz2
gentoo-84e1235e06adc2273e96a9c1351e74f61aeb8b21.zip
dev-python/frozen-flask: Bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/frozen-flask/frozen-flask-0.13.ebuild')
-rw-r--r--dev-python/frozen-flask/frozen-flask-0.13.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/frozen-flask/frozen-flask-0.13.ebuild b/dev-python/frozen-flask/frozen-flask-0.13.ebuild
new file mode 100644
index 000000000000..8ce2fb536796
--- /dev/null
+++ b/dev-python/frozen-flask/frozen-flask-0.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Frozen-Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Freezes a Flask application into a set of static files"
+HOMEPAGE="https://github.com/SimonSapin/Frozen-Flask https://pypi.python.org/pypi/Frozen-Flask"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sed -e 's:^intersphinx_mapping:#intersphinx_mapping:' -i docs/conf.py || die
+ mkdir docs/_build || die
+ sphinx-build -c docs docs docs/_build || die
+ fi
+}
+
+python_test() {
+ nosetests || die Tests failed under $"{EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/. )
+ distutils-r1_python_install_all
+}