summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 09:49:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 12:40:38 +0100
commit0a9d6e8aa0f55e60dc47672356c7ed6a680a8f22 (patch)
tree889da413e45c3f5eb8b2c0d71d7ca3408e8e6160 /dev-python/frozenlist
parentdev-perl/HTML-Strip: EAPI=8 bump (diff)
downloadgentoo-0a9d6e8aa0f55e60dc47672356c7ed6a680a8f22.tar.gz
gentoo-0a9d6e8aa0f55e60dc47672356c7ed6a680a8f22.tar.bz2
gentoo-0a9d6e8aa0f55e60dc47672356c7ed6a680a8f22.zip
dev-python/frozenlist: New package, dep of dev-python/aiosignal
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/frozenlist')
-rw-r--r--dev-python/frozenlist/Manifest1
-rw-r--r--dev-python/frozenlist/frozenlist-1.2.0.ebuild39
-rw-r--r--dev-python/frozenlist/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
new file mode 100644
index 000000000000..bf51b5a40783
--- /dev/null
+++ b/dev-python/frozenlist/Manifest
@@ -0,0 +1 @@
+DIST frozenlist-1.2.0.gh.tar.gz 29062 BLAKE2B cc82db759906ad3e0be1806cacd6815377f264ed07ed272abb7da4753c11561564cf1cb4dfc0154abaeb4005f5607c26e602410a4ef45dd8e94e26583caa2ab7 SHA512 e5dda13e173db0b1c6e8c5a61949534f4eb30211cc4fcd102d0be1b55ee48e2db90d52fd770a2c6d6076f3a0d9e11289629a7a115c1270377636eda35d107e7a
diff --git a/dev-python/frozenlist/frozenlist-1.2.0.ebuild b/dev-python/frozenlist/frozenlist-1.2.0.ebuild
new file mode 100644
index 000000000000..ba892fcc5c1d
--- /dev/null
+++ b/dev-python/frozenlist/frozenlist-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
+HOMEPAGE="
+ https://pypi.org/project/frozenlist/
+ https://github.com/aio-libs/frozenlist/"
+SRC_URI="
+ https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ # pypy is not using the C extension
+ if [[ ${EPYTHON} == python* ]]; then
+ > .install-cython || die
+ emake cythonize
+ fi
+}
diff --git a/dev-python/frozenlist/metadata.xml b/dev-python/frozenlist/metadata.xml
new file mode 100644
index 000000000000..c3f806ae6504
--- /dev/null
+++ b/dev-python/frozenlist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">frozenlist</remote-id>
+ <remote-id type="github">aio-libs/frozenlist</remote-id>
+ </upstream>
+</pkgmetadata>