summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-05 19:24:36 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-05 20:45:03 +0100
commitba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b (patch)
tree22b6087300d3278355e47e1d202b97e3d03c9629 /dev-python/fs/fs-0.5.4.ebuild
parentdev-python/mako: Add pypy support (diff)
downloadgentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.tar.gz
gentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.tar.bz2
gentoo-ba9836121c5b9c44f59c2c2e7cbfc1ba2590b73b.zip
dev-python/fs: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/fs/fs-0.5.4.ebuild')
-rw-r--r--dev-python/fs/fs-0.5.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fs/fs-0.5.4.ebuild b/dev-python/fs/fs-0.5.4.ebuild
new file mode 100644
index 000000000000..f5e662e6602f
--- /dev/null
+++ b/dev-python/fs/fs-0.5.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ http://pypi.python.org/pypi/fs
+ http://docs.pyfilesystem.org
+ http://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/dexml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# Tries to access FUSE
+RESTRICT=test
+
+python_test() {
+ nosetests --verbose || die
+}
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}