summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-05-09 23:45:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-09 23:45:19 +0200
commit20d0399a188130dec75ba3493bfb6847d2e358b2 (patch)
treeab0049d4e985a69ebb20ba84327e29ea434053dc /dev-python/fs
parentgames-util/nml: Add python3_6 to PYTHON_COMPAT (diff)
downloadgentoo-20d0399a188130dec75ba3493bfb6847d2e358b2.tar.gz
gentoo-20d0399a188130dec75ba3493bfb6847d2e358b2.tar.bz2
gentoo-20d0399a188130dec75ba3493bfb6847d2e358b2.zip
dev-python/fs: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest1
-rw-r--r--dev-python/fs/fs-2.0.21.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index 4daae10d2649..26a30a587fdc 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1 +1,2 @@
DIST fs-0.5.4.tar.gz 231333 BLAKE2B 2211aedf02a3eab809b7bfeabe346ed147465db52ef6a069ab3cea6f62e3b420d52b9a58868c3eaab55bd9a6c8c071c5c090e28e9dbfccd182385beee3e246c8 SHA512 d67c85f2816cf1a84c25664a6cf71dac551c3eec4eb34154bc92d52eb0efa9739adca6d0ec86b9978ff6af408cfa17b913ee8fd4c143cd2adf862ca0a1dd4c5d
+DIST fs-2.0.21.tar.gz 115844 BLAKE2B 0f7b3fa087c89a68c27d350233e3e73fa54b761bad7799a895fd79fb5a7df898df381e82bd160ccb782e7e814b00041d3cd309860c96b4ea5dc3078e6d33430b SHA512 d16e02a6ed78a26229b12e71f6286db0243774ae13f6f3d0a6c4fb9240fe65656e4f10cb2b385342fb48d12a163ca33a0b746854ab5ee240eae0ff8f6644ed13
diff --git a/dev-python/fs/fs-2.0.21.ebuild b/dev-python/fs/fs-2.0.21.ebuild
new file mode 100644
index 000000000000..c657c5f97cf5
--- /dev/null
+++ b/dev-python/fs/fs-2.0.21.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/dexml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+# Tries to access FUSE
+RESTRICT=test
+
+python_test() {
+ nosetests --verbose || die
+}
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}