summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-24 12:17:51 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-24 12:19:22 -0500
commitabe149946038cd4d9f27c9502a30bacda8751a36 (patch)
treec5c55774733f6cc2370e41da6a4de7b7cd328204 /dev-python/fs
parentmedia-gfx/graphviz: Drop 2.40.1-r1 (diff)
downloadgentoo-abe149946038cd4d9f27c9502a30bacda8751a36.tar.gz
gentoo-abe149946038cd4d9f27c9502a30bacda8751a36.tar.bz2
gentoo-abe149946038cd4d9f27c9502a30bacda8751a36.zip
dev-python/fs: restrict tests for py2.7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.9.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/fs/fs-2.4.9.ebuild b/dev-python/fs/fs-2.4.9.ebuild
index adf7a05eb3ee..bf26e5723f5f 100644
--- a/dev-python/fs/fs-2.4.9.ebuild
+++ b/dev-python/fs/fs-2.4.9.ebuild
@@ -18,6 +18,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
@@ -32,13 +33,15 @@ DEPEND="${RDEPEND}
dev-python/pyftpdlib[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
- python_targets_python2_7? (
- dev-python/backports-os[python_targets_python2_7]
- )
- )"
+ )
+"
python_test() {
- esetup.py test
+ # python2_7 tests require dev-python/typing which is
+ # now in stdlib so ignore tests. py2.7 is going away.
+ if python_is_python3; then
+ esetup.py test || die "tests failed"
+ fi
}
pkg_postinst() {