summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-17 22:51:27 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-17 22:51:27 +0100
commita7839110408861905267d18c7cca6d78f4dbeafe (patch)
tree44709271ed342bc55cd2423a3a494d479acba631 /dev-python/fsspec/fsspec-2021.11.1.ebuild
parentdev-python/python-socks: Remove old (diff)
downloadgentoo-a7839110408861905267d18c7cca6d78f4dbeafe.tar.gz
gentoo-a7839110408861905267d18c7cca6d78f4dbeafe.tar.bz2
gentoo-a7839110408861905267d18c7cca6d78f4dbeafe.zip
dev-python/fsspec: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec/fsspec-2021.11.1.ebuild')
-rw-r--r--dev-python/fsspec/fsspec-2021.11.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/fsspec/fsspec-2021.11.1.ebuild b/dev-python/fsspec/fsspec-2021.11.1.ebuild
deleted file mode 100644
index 5db1980e9666..000000000000
--- a/dev-python/fsspec/fsspec-2021.11.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P=filesystem_spec-${PV}
-DESCRIPTION="A specification that python filesystems should adhere to"
-HOMEPAGE="https://github.com/fsspec/filesystem_spec/
- https://pypi.org/project/fsspec/"
-SRC_URI="
- https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-BDEPEND="
- dev-python/versioneer[${PYTHON_USEDEP}]
- test? (
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-distutils_enable_tests pytest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- distutils-r1_src_test
-}
-
-EPYTEST_DESELECT=(
- fsspec/tests/test_spec.py::test_find
-)
-
-EPYTEST_IGNORE=(
- # sftp and smb require server started via docker
- fsspec/implementations/tests/test_dbfs.py
- fsspec/implementations/tests/test_sftp.py
- fsspec/implementations/tests/test_smb.py
-)