summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 21:59:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:53 +0300
commit064b9d10186cac8a5eab56cf1c20a8e3e843b836 (patch)
treef3bbb23e7bc5bab19d8b4624e3fc33ebe790e0ea /dev-python/fsspec
parentdev-python/swagger-spec-validator: enable py3.11 (diff)
downloadgentoo-064b9d10186cac8a5eab56cf1c20a8e3e843b836.tar.gz
gentoo-064b9d10186cac8a5eab56cf1c20a8e3e843b836.tar.bz2
gentoo-064b9d10186cac8a5eab56cf1c20a8e3e843b836.zip
dev-python/fsspec: add 2022.8.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2022.8.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 0a97cead7eae..7eaf3477868f 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,3 +1,4 @@
DIST filesystem_spec-2022.7.1.gh.tar.gz 338526 BLAKE2B ef19c41a4e9fe3fb1a5146967bab505c26590aa4c074152523b705d8cac5eeb6e30834e1adbbb1669f5bbb58891cabd3960208cdfa9f619e0bbc5cbfe5f4ef55 SHA512 07178bf22e07091935256296b303e273c03e2ddc15a5aa1110f84c27cadaf9c650204e37c472cb10280e92f24b01fa8b16fe32db21a30d14d232c5a11e05a45c
DIST filesystem_spec-2022.8.0.gh.tar.gz 338839 BLAKE2B 6d70e20a435caab098db2437137fcd80efdcb08ff3018daf5c72ceb958fcca354eb6a12a525ea023fd042cf54099fe991a444c3627989bc3f0e38bddd8d57aca SHA512 843ee51d7dec362623ebe584def6bb7c8b5521434befd89bba178969bb9fbe53b9b488f0f8d301d600fe2f97e876a6b74f92c9d0e9b8941aaa70f5514e6516ee
DIST filesystem_spec-2022.8.1.gh.tar.gz 338463 BLAKE2B e155dfecf1d9cae7f436f9387e9c1e822205f74a7b7484089fa1a7567d1293d699ba4a3ef8f9453720a22fbc41dedfed0455da64a46b7458c7b39d2a5d4f8c29 SHA512 ab37ba926ea834fa2938e851e2f273c624400165b097642ba2b103a126b8d8cdc9acf7a5683ad2fa5df24dbe3c1ec2b228683b8c3489af917b13729f8bef0c0b
+DIST filesystem_spec-2022.8.2.gh.tar.gz 338456 BLAKE2B 79208de0f7c694f9e247a0d4589d439fd80f07a893df9dbaeeb1ec01bb1dfe2ba6c73f70fa60e5109cf076aa104cef81ab247fc26172be2b0317a108f5aae75f SHA512 2d288ace6469af4a90475f33f2a662ab2696b3c974539b7f41c3fc86699c9d3da8f1cfdff7be2a228d8c7eda02c1ca6558690cdeab0847b007235d2b866f3c2a
diff --git a/dev-python/fsspec/fsspec-2022.8.2.ebuild b/dev-python/fsspec/fsspec-2022.8.2.ebuild
new file mode 100644
index 000000000000..dba46d7fc2e2
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2022.8.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+)