summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 08:38:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 09:12:24 +0100
commit32f338336ad6140a46317b7e95eb4fbb557c9f70 (patch)
treee78f14912a3710ac2e78e6cf31dc4cd1efa4d088 /dev-python/fsspec
parentdev-python/python-slugify: Bump to 6.1.0 (diff)
downloadgentoo-32f338336ad6140a46317b7e95eb4fbb557c9f70.tar.gz
gentoo-32f338336ad6140a46317b7e95eb4fbb557c9f70.tar.bz2
gentoo-32f338336ad6140a46317b7e95eb4fbb557c9f70.zip
dev-python/fsspec: Bump to 2022.02.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2022.02.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 150ef358bf57..97e14ea7d6b8 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2022.01.0.tar.gz 325470 BLAKE2B 1a6dccad133a449ba9b78516f968586a0f300e97150a6aa887f2f65fafe6e2bae708620ef185789024a7248877405d736839292011f3db2221c119fb80bbb5ac SHA512 50e36c9aded9ee9824694bad563b8e92ee564c6fb6fc30d3a51b8b2e8b4a1e5f605fdbaff00eefb354b0201cce4bced0ed95b48817c5ef15ad1f09965d311ac0
+DIST filesystem_spec-2022.02.0.tar.gz 329625 BLAKE2B c3d3815ece4cc3a0713d2ee6fd70c55a3236c926dd389dd55866bd6a11c63e6225cd4415dd310876b8e271bf82534826452a3327693f94bd8c8b5b7aa7893222 SHA512 6cc26cb61c75fea4ab7af37190a623a4fa07d85ff540accc4d85e8ebab5f6bcc78099e85a6196f93c9d7f4e0e0380395ad2625b485858fb8db40f7c2682f8c4d
diff --git a/dev-python/fsspec/fsspec-2022.02.0.ebuild b/dev-python/fsspec/fsspec-2022.02.0.ebuild
new file mode 100644
index 000000000000..ff6a3a18e84f
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2022.02.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)