summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:26:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:19 +0200
commit63e0daf4f6e2cbccfeaec077198460417f7a9fe1 (patch)
tree7e34a92c518fb9efb239d334f9b6de27b9ce4491 /dev-python/fsspec
parentdev-python/identify: Bump to 2.5.1 (diff)
downloadgentoo-63e0daf4f6e2cbccfeaec077198460417f7a9fe1.tar.gz
gentoo-63e0daf4f6e2cbccfeaec077198460417f7a9fe1.tar.bz2
gentoo-63e0daf4f6e2cbccfeaec077198460417f7a9fe1.zip
dev-python/fsspec: Bump to 2022.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2022.5.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index dffbb50a516f..79af5bd7ee31 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2022.3.0.tar.gz 331768 BLAKE2B 8f4e75f839419f7445a9291e3b67914338b0371742f1d3a556962b6e5abb31379cfeba52e0101f7660fd69569dabb49190820323b7e067a0c33c2184422ba067 SHA512 7c793b506e93f727bc4533a778f6108f82c9ab9274a8d259ecf483e0acbbfc97e3c8b07735f772f996867053d7e1f9c22687865f4f64cae6eb4fb511de2e9220
+DIST filesystem_spec-2022.5.0.tar.gz 337612 BLAKE2B 722ce370d0cfa97548956ea8bfc533ded3eadfb6a1fdfbb83513fad4fbfd34e2d700ae69ede812b7ba132beb29ab18914852487b94b2a8e5de4b106d6f554eca SHA512 9ea8040d5f94c3b0d3c21df7b27413e0a9a4f96973c961e3f88238adcf69a9c866790370c3d8b0149aa85d0bda67e72f7b75a2a9ff1c27e5171a4f0e41e3ffe9
diff --git a/dev-python/fsspec/fsspec-2022.5.0.ebuild b/dev-python/fsspec/fsspec-2022.5.0.ebuild
new file mode 100644
index 000000000000..8d4e5c08b93c
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2022.5.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+)