summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 23:53:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 00:19:48 +0100
commitff76c242a809e92606f5404be7427701736c7d46 (patch)
treea33e18e6e39af39f1e54024471741bf2d534f95a /dev-python/funcparserlib
parentdev-python/enrich: Switch to PEP 517 build (diff)
downloadgentoo-ff76c242a809e92606f5404be7427701736c7d46.tar.gz
gentoo-ff76c242a809e92606f5404be7427701736c7d46.tar.bz2
gentoo-ff76c242a809e92606f5404be7427701736c7d46.zip
dev-python/funcparserlib: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/funcparserlib')
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild
new file mode 100644
index 000000000000..3a82a59f0c12
--- /dev/null
+++ b/dev-python/funcparserlib/funcparserlib-1.0.0_alpha0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://pypi.org/project/funcparserlib/"
+SRC_URI="
+ https://github.com/vlasovskikh/funcparserlib/archive/${MY_PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="test? ( dev-python/six[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ local DOCS=( doc/*.md )
+ distutils-r1_python_install_all
+}