summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-12-19 16:57:09 +0100
committerAlfredo Tupone <tupone@gentoo.org>2020-12-19 16:57:09 +0100
commit659820a2c00645639e49e058018df06fe1c23089 (patch)
tree6ae09f73e5178e9e3f84e1233596cb5b6c6390bc /dev-python/funcy
parentdev-python/whatever: Add in the tree (diff)
downloadgentoo-659820a2c00645639e49e058018df06fe1c23089.tar.gz
gentoo-659820a2c00645639e49e058018df06fe1c23089.tar.bz2
gentoo-659820a2c00645639e49e058018df06fe1c23089.zip
dev-python/funcy: Add test
Closes: https://bugs.gentoo.org/731832 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/funcy-1.14.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/funcy/funcy-1.14.ebuild b/dev-python/funcy/funcy-1.14.ebuild
index dbae274d8803..babc4c8350dd 100644
--- a/dev-python/funcy/funcy-1.14.ebuild
+++ b/dev-python/funcy/funcy-1.14.ebuild
@@ -13,7 +13,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND=""
RDEPEND="${DEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest || die "Tests fail with ${EPYTHON}"
+}