summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-01-12 09:03:37 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-01-12 09:03:37 +0100
commit9dc80bc578aaef1a71ecb87cf596940b4d1ce39c (patch)
tree458d95ed4751f05975b7f4e62c9262ecc2419989 /dev-python/funcy
parentdev-python/quex: adding upstream in metadata (diff)
downloadgentoo-9dc80bc578aaef1a71ecb87cf596940b4d1ce39c.tar.gz
gentoo-9dc80bc578aaef1a71ecb87cf596940b4d1ce39c.tar.bz2
gentoo-9dc80bc578aaef1a71ecb87cf596940b4d1ce39c.zip
dev-python/funcy: version bump to 1.15
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/Manifest1
-rw-r--r--dev-python/funcy/funcy-1.15.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/funcy/Manifest b/dev-python/funcy/Manifest
index b7800498468f..9b181f1cc7e2 100644
--- a/dev-python/funcy/Manifest
+++ b/dev-python/funcy/Manifest
@@ -1 +1,2 @@
DIST funcy-1.14.tar.gz 548493 BLAKE2B fff352d0e0d685fb51fb30302542c2e8893209df1e01912efae06821fbc885b05ab3fea8786d6924b48ddf32cc6bdd6def5e90db1ff949b005437b5d3771c3c0 SHA512 0c7daf1a6d87f56663ae0d37cc65654c79646c313ec530ac57e6ee8de04849b8846556fda10dd762f92e44a5ffa54d32880bed4cd77cec99ae865de0203d123a
+DIST funcy-1.15.tar.gz 605884 BLAKE2B dbcfe02981a09b2914096c7df9e0f37582dd4250bced71df92a1b10ce655291470f5ecb32ea4557307ba075e121d3199e0928566f9c25256c391ab821363023b SHA512 6e54da954bf11de55251a2732e9cee5617947322ea16a6a918ff3c5d7cb448756d29a39c4e997186cadc30d24270ccf4e6d21af9f108ebaabaed68e0be96f624
diff --git a/dev-python/funcy/funcy-1.15.ebuild b/dev-python/funcy/funcy-1.15.ebuild
new file mode 100644
index 000000000000..c6242b5bfe8a
--- /dev/null
+++ b/dev-python/funcy/funcy-1.15.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/whatever[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest || die "Tests fail with ${EPYTHON}"
+}