summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-29 00:05:30 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-29 00:05:30 -0400
commit0a2b11c56e405d3b70a6e52101f3f3945d1cbfa0 (patch)
tree00adbc96e91c2ed1a15655c5c44e50ab01b908c7 /dev-python/future
parentdev-python/xlsxwriter-1.2.8: Version bump (diff)
downloadgentoo-0a2b11c56e405d3b70a6e52101f3f3945d1cbfa0.tar.gz
gentoo-0a2b11c56e405d3b70a6e52101f3f3945d1cbfa0.tar.bz2
gentoo-0a2b11c56e405d3b70a6e52101f3f3945d1cbfa0.zip
dev-python/future: DISTUTILS_USE_SETUPTOOLS=rdepend
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/future-0.18.2.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/future/future-0.18.2.ebuild b/dev-python/future/future-0.18.2.ebuild
index 5e88bab00882..15d4b3fa213e 100644
--- a/dev-python/future/future-0.18.2.ebuild
+++ b/dev-python/future/future-0.18.2.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -16,19 +16,16 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx-bootstrap-theme
-
# TODO: make numpy unconditional when it supports py3.8
-BDEPEND+="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- python{2_7,3_{5,6,7}})
+ $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' python{2_7,3_{5,6,7}})
)
"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme
+
PATCHES=(
"${FILESDIR}"/${P}-tests.patch
)