summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-20 10:22:36 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-20 10:43:26 +0300
commit11efb934eb4327332e39514e76f89334ee9f8718 (patch)
tree91a8bdbed691f4189db7ec503429ca445dbd769a /dev-python/future
parentdev-python/future: add github upstream metadata (diff)
downloadgentoo-11efb934eb4327332e39514e76f89334ee9f8718.tar.gz
gentoo-11efb934eb4327332e39514e76f89334ee9f8718.tar.bz2
gentoo-11efb934eb4327332e39514e76f89334ee9f8718.zip
dev-python/future: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/files/future-0.18.2-py3.10.patch29
-rw-r--r--dev-python/future/future-0.18.2-r1.ebuild16
2 files changed, 36 insertions, 9 deletions
diff --git a/dev-python/future/files/future-0.18.2-py3.10.patch b/dev-python/future/files/future-0.18.2-py3.10.patch
new file mode 100644
index 000000000000..65cbc8e7a40d
--- /dev/null
+++ b/dev-python/future/files/future-0.18.2-py3.10.patch
@@ -0,0 +1,29 @@
+From ca1362a4250b7124d9ae03506eb80a767f06e282 Mon Sep 17 00:00:00 2001
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Fri, 20 Aug 2021 10:15:59 +0300
+Subject: [PATCH] Fix for Python3.10
+
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+---
+ src/future/moves/test/support.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/future/moves/test/support.py b/src/future/moves/test/support.py
+index e9aa0f4..4ae2ffd 100644
+--- a/src/future/moves/test/support.py
++++ b/src/future/moves/test/support.py
+@@ -3,6 +3,11 @@ from future.standard_library import suspend_hooks
+ from future.utils import PY3
+
+ if PY3:
++ try:
++ from test.support.os_helper import *
++ from test.support.warnings_helper import *
++ except ImportError:
++ pass
+ from test.support import *
+ else:
+ __future_module__ = True
+--
+2.33.0
+
diff --git a/dev-python/future/future-0.18.2-r1.ebuild b/dev-python/future/future-0.18.2-r1.ebuild
index 653a507983cb..ab4b1b6f3c42 100644
--- a/dev-python/future/future-0.18.2-r1.ebuild
+++ b/dev-python/future/future-0.18.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
@@ -13,7 +13,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
BDEPEND="
test? (
@@ -29,13 +28,12 @@ PATCHES=(
"${FILESDIR}"/${P}-tests.patch
"${FILESDIR}"/${P}-py39.patch
"${FILESDIR}"/${P}-py39-fileurl.patch
+ "${FILESDIR}"/${P}-py3.10.patch
)
-python_prepare_all() {
+EPYTEST_DESELECT=(
# tests requiring network access
- rm tests/test_future/test_requests.py || die
- sed -i -e 's:test.*request_http:_&:' \
- tests/test_future/test_standard_library.py || die
-
- distutils-r1_python_prepare_all
-}
+ tests/test_future/test_requests.py
+ tests/test_future/test_standard_library.py::TestStandardLibraryReorganization::test_moves_urllib_request_http
+ tests/test_future/test_standard_library.py::TestStandardLibraryReorganization::test_urllib_request_http
+)