summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-05-01 11:11:23 +0200
committerDavid Seifert <soap@gentoo.org>2019-05-01 11:11:23 +0200
commitd3e1798c98b73a6df4aa3abefda30fce1f266fb6 (patch)
tree3407b8c9055bd9ccd283e80bd8d411305e701389 /dev-python/future
parentdev-util/conan: Relax dependencies (diff)
downloadgentoo-d3e1798c98b73a6df4aa3abefda30fce1f266fb6.tar.gz
gentoo-d3e1798c98b73a6df4aa3abefda30fce1f266fb6.tar.bz2
gentoo-d3e1798c98b73a6df4aa3abefda30fce1f266fb6.zip
dev-python/future: Remove old
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/future')
-rw-r--r--dev-python/future/Manifest2
-rw-r--r--dev-python/future/files/future-0.15.2-fix-py35-test-failures.patch57
-rw-r--r--dev-python/future/files/future-0.16.0-disable-tests-with-internet-connection.patch50
-rw-r--r--dev-python/future/files/future-0.16.0-fix-tests-py37.patch43
-rw-r--r--dev-python/future/future-0.15.2.ebuild23
-rw-r--r--dev-python/future/future-0.16.0-r1.ebuild52
-rw-r--r--dev-python/future/future-0.16.0.ebuild27
7 files changed, 0 insertions, 254 deletions
diff --git a/dev-python/future/Manifest b/dev-python/future/Manifest
index 0bcf5ff7b5a1..48c79e5ce1a9 100644
--- a/dev-python/future/Manifest
+++ b/dev-python/future/Manifest
@@ -1,3 +1 @@
-DIST future-0.15.2.tar.gz 1583441 BLAKE2B 9c552a5f3598922f8910480d054015020112aae4f7e14d2c139dda13a0b26e878b75eaf5068d66f20823ac4659d85edd4087a95d9474dc27bf15767cf6e9d921 SHA512 24a0eaf70795efe1644b098c5abbcb0103d9172a5243721f0d26b1cbd108872b6c0616180da8f5507855ddfc7b26bb10a606a64e59d307d39042b346700f77ee
-DIST future-0.16.0.tar.gz 824484 BLAKE2B b098366cc7a7866c4aa4a35f1a6a5cf113698307de8f4cce6c77e4ce72a8433dd102111f991e35ffa920c09a0d31cc048b9502dacd0aba1b701c11eaaeab8392 SHA512 41c795cd1746a76df84de2da9fbc611fc6164322c1c712ec9e8a8626c21c2717cb4899ec150d95c5e0c037270e6bb71e099edd169609369aae619daea9df2e5f
DIST future-0.17.0.tar.gz 827812 BLAKE2B 14bfce4927386b157da91e6bbad547e21bb622f7e81997bc4ac400842cec5f7a50d7a0f5a743c4c76a7b80be0dcb6f54c06901311fd27781d89a8d2df1cce7e9 SHA512 f2396379e8e36753aeafdf27225c2551a31b10036f21201f1c24d63c1bb318dbd491ec977af514a19a4d477b397df9eed9711be797a64e86fc00c4692729d876
diff --git a/dev-python/future/files/future-0.15.2-fix-py35-test-failures.patch b/dev-python/future/files/future-0.15.2-fix-py35-test-failures.patch
deleted file mode 100644
index 8d8e5daccf10..000000000000
--- a/dev-python/future/files/future-0.15.2-fix-py35-test-failures.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-* Fix test failures on py3.5, backported from git, see also
- https://github.com/PythonCharmers/python-future/issues/183
-* Fix unexpected test successes on py3.5, which are now correct
-
---- a/tests/test_future/test_bytes.py
-+++ b/tests/test_future/test_bytes.py
-@@ -10,6 +10,8 @@
- from numbers import Integral
- from future.tests.base import unittest, expectedFailurePY2
-
-+import sys
-+
-
- TEST_UNICODE_STR = u'ℝεα∂@ßʟ℮ ☂ℯṧт υηḯ¢☺ḓ℮'
- # Tk icon as a .gif:
-@@ -534,6 +536,8 @@
- self.assertRaises(ValueError, bytes.maketrans, b'abc', b'xyzq')
- self.assertRaises(TypeError, bytes.maketrans, 'abc', 'def')
-
-+ @unittest.skipIf(sys.version_info[:2] == (3, 5),
-+ 'Only works in Py3.5+')
- @unittest.expectedFailure
- def test_mod(self):
- """
-@@ -551,6 +555,8 @@
- a = b % (b'seventy-nine', 79)
- self.assertEqual(a, b'seventy-nine / 100 = 79%')
-
-+ @unittest.skipIf(sys.version_info[:2] == (3, 5),
-+ 'Only works in Py3.5+')
- @unittest.expectedFailure
- def test_imod(self):
- """
---- a/tests/test_future/test_builtins.py
-+++ b/tests/test_future/test_builtins.py
-@@ -525,11 +525,10 @@
- self.assertRaises(ValueError, compile, 'print(42)\n', '<string>', 'badmode')
- self.assertRaises(ValueError, compile, 'print(42)\n', '<string>', 'single', 0xff)
- # Raises TypeError in Python < v3.5, ValueError in v3.5:
-- # self.assertRaises(TypeError, compile, chr(0), 'f', 'exec')
-+ self.assertRaises((TypeError, ValueError), compile, chr(0), 'f', 'exec')
- self.assertRaises(TypeError, compile, 'pass', '?', 'exec',
- mode='eval', source='0', filename='tmp')
- compile('print("\xe5")\n', '', 'exec')
-- self.assertRaises(TypeError, compile, chr(0), 'f', 'exec')
- self.assertRaises(ValueError, compile, str('a = 1'), 'f', 'bad')
-
- # test the optimize argument
-@@ -1287,7 +1286,7 @@
- self.assertAlmostEqual(pow(-1, 1/3), 0.5 + 0.8660254037844386j)
-
- # Raises TypeError in Python < v3.5, ValueError in v3.5:
-- # self.assertRaises(TypeError, pow, -1, -2, 3)
-+ self.assertRaises((TypeError, ValueError), pow, -1, -2, 3)
- self.assertRaises(ValueError, pow, 1, 2, 0)
-
- self.assertRaises(TypeError, pow)
diff --git a/dev-python/future/files/future-0.16.0-disable-tests-with-internet-connection.patch b/dev-python/future/files/future-0.16.0-disable-tests-with-internet-connection.patch
deleted file mode 100644
index b4ba01ed796a..000000000000
--- a/dev-python/future/files/future-0.16.0-disable-tests-with-internet-connection.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-##Skipping tests due to connection failures on Fedora build-system
-##See https://github.com/PythonCharmers/python-future/issues/165
-
---- a/tests/test_future/test_standard_library.orig.py 2014-11-21 12:52:03.000000000 +0100
-+++ b/tests/test_future/test_standard_library.py 2015-09-02 11:37:36.808826777 +0200
-@@ -318,7 +318,7 @@
- import builtins
- self.assertTrue(hasattr(builtins, 'tuple'))
-
-- # @unittest.skip("ssl support has been stripped out for now ...")
-+ @unittest.skip("ConnectionError: ('Connection aborted.', gaierror(-3, 'Temporary failure in name resolution'))...")
- def test_urllib_request_ssl_redirect(self):
- """
- This site redirects to https://...
-@@ -332,6 +332,7 @@
- # pprint(r.read().decode('utf-8'))
- self.assertTrue(True)
-
-+ @unittest.skip("ConnectionError: ('Connection aborted.', gaierror(-3, 'Temporary failure in name resolution'))...")
- def test_moves_urllib_request_http(self):
- """
- This site (python-future.org) uses plain http (as of 2014-09-23).
-@@ -343,6 +343,7 @@
- data = r.read()
- self.assertTrue(b'</html>' in data)
-
-+ @unittest.skip("ConnectionError: ('Connection aborted.', gaierror(-3, 'Temporary failure in name resolution'))...")
- def test_urllib_request_http(self):
- """
- This site (python-future.org) uses plain http (as of 2014-09-23).
-
---- a/tests/test_future/test_requests.orig.py 2014-11-21 12:52:03.000000000 +0100
-+++ b/tests/test_future/test_requests.py 2015-09-02 11:39:01.509378296 +0200
-@@ -57,6 +57,7 @@
- This class tests whether the requests module conflicts with the
- standard library import hooks, as in issue #19.
- """
-+ @unittest.skip("ConnectionError: ('Connection aborted.', gaierror(-3, 'Temporary failure in name resolution'))...")
- def test_remove_hooks_then_requests(self):
- code = """
- from future import standard_library
-@@ -79,6 +80,7 @@
- self.assertTrue(True)
-
-
-+ @unittest.skip("ConnectionError: ('Connection aborted.', gaierror(-3, 'Temporary failure in name resolution'))...")
- def test_requests_cm(self):
- """
- Tests whether requests can be used importing standard_library modules
-
diff --git a/dev-python/future/files/future-0.16.0-fix-tests-py37.patch b/dev-python/future/files/future-0.16.0-fix-tests-py37.patch
deleted file mode 100644
index d925d49f983e..000000000000
--- a/dev-python/future/files/future-0.16.0-fix-tests-py37.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-commit ce4f015978d250718ec8dd9f50721da90a9bd18b
-Author: Louis Sautier <sautier.louis@gmail.com>
-Date: Mon Aug 20 12:42:29 2018 +0200
-
- Skip int() keyword tests with Python 3.7
-
- The first argument must be positional since
- https://github.com/python/cpython/commit/2e5642422f6234fd8d0c082142b27340e588f96e
-
-diff --git a/tests/test_future/test_int.py b/tests/test_future/test_int.py
-index f1d9c5d..e306550 100644
---- a/tests/test_future/test_int.py
-+++ b/tests/test_future/test_int.py
-@@ -265,6 +265,9 @@ class IntTestCases(unittest.TestCase):
- def test_no_args(self):
- self.assertEqual(int(), 0)
-
-+ @unittest.skipIf(sys.version_info >= (3, 7),
-+ "The first parameter must be positional with Python >= 3.7"
-+ )
- def test_keyword_args(self):
- # Test invoking int() using keyword arguments.
- self.assertEqual(int(x=1.2), 1)
-
-commit d7a3451753982d944ae0894c9e9f01d0460d03d5
-Author: Louis Sautier <sautier.louis@gmail.com>
-Date: Mon Aug 20 11:17:59 2018 +0200
-
- Make test_bad_status_repr work for Python 3.7
-
-diff --git a/tests/test_future/test_httplib.py b/tests/test_future/test_httplib.py
-index 968e933..a1e2b19 100644
---- a/tests/test_future/test_httplib.py
-+++ b/tests/test_future/test_httplib.py
-@@ -197,7 +197,7 @@ class BasicTest(TestCase):
- if not utils.PY3:
- self.assertEqual(repr(exc), '''BadStatusLine("u\'\'",)''')
- else:
-- self.assertEqual(repr(exc), '''BadStatusLine("\'\'",)''')
-+ self.assertIn(repr(exc), ('''BadStatusLine("''",)''', '''BadStatusLine("''")'''))
-
- def test_partial_reads(self):
- # if we have a length, the system knows when to close itself
diff --git a/dev-python/future/future-0.15.2.ebuild b/dev-python/future/future-0.15.2.ebuild
deleted file mode 100644
index 7cc10e8da844..000000000000
--- a/dev-python/future/future-0.15.2.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
-HOMEPAGE="http://python-future.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa x86"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${P}-fix-py35-test-failures.patch" )
-
-python_test() {
- esetup.py test || die
-}
diff --git a/dev-python/future/future-0.16.0-r1.ebuild b/dev-python/future/future-0.16.0-r1.ebuild
deleted file mode 100644
index e65bb99c9ec8..000000000000
--- a/dev-python/future/future-0.16.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
-HOMEPAGE="http://python-future.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/PythonCharmers/python-future/issues/165
- "${FILESDIR}/${P}-disable-tests-with-internet-connection.patch"
- # https://github.com/PythonCharmers/python-future/pull/355
- "${FILESDIR}/${P}-fix-tests-py37.patch"
-)
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs/ docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/future/future-0.16.0.ebuild b/dev-python/future/future-0.16.0.ebuild
deleted file mode 100644
index aa4638b61ae6..000000000000
--- a/dev-python/future/future-0.16.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easy, clean, reliable Python 2/3 compatibility"
-HOMEPAGE="http://python-future.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 ~sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}