summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 23:37:10 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 00:35:21 +0100
commit0e9ef0b22c697cfdc7b421e73e823442278d636b (patch)
tree87b4ef12958cfde735f80a87066e161eec094a86 /dev-python/futures
parentdev-python/frozen-flask: Clean old up (diff)
downloadgentoo-0e9ef0b22c697cfdc7b421e73e823442278d636b.tar.gz
gentoo-0e9ef0b22c697cfdc7b421e73e823442278d636b.tar.bz2
gentoo-0e9ef0b22c697cfdc7b421e73e823442278d636b.zip
dev-python/futures: Clean old up
Diffstat (limited to 'dev-python/futures')
-rw-r--r--dev-python/futures/Manifest1
-rw-r--r--dev-python/futures/futures-2.2.0.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/futures/Manifest b/dev-python/futures/Manifest
index d5ed0a200adc..c1ad46028f94 100644
--- a/dev-python/futures/Manifest
+++ b/dev-python/futures/Manifest
@@ -1,3 +1,2 @@
-DIST futures-2.2.0.tar.gz 26786 BLAKE2B 61fc83741b00c735bb28e1ab01356440f294b1e9539e31460ef2d36ce786e191a5ac03bf55b08c62d5003becd2505378e5cd5cce45583d0adfefe9997934100f SHA512 5f2a835b4b3f6bf1c4f086984a2e1d6ab30004b9af9298ef8afb23549014695ba26b43500dad3ee873e52aacd75911a42cd4ec9dfae6522cb99476a480dc83ee
DIST futures-3.0.3.tar.gz 24959 BLAKE2B 2888284e00d6fa6532c19088b058d2b7e153b1df9fde4e004467cb06a64c2c9947d0aa23ecba0171db9c905d0ee6851dde9bc64a276de6a5044453f29c5020fa SHA512 2fa14df90e583ca86c47441b170a93435eb82fd37bb2e15d98e79c32fbe40fc3f602d762805de05fa8007df4a3ce92840915be59481b94ab4863aae884da74bd
DIST futures-3.1.1.tar.gz 26471 BLAKE2B 53c7678cec213351bc1c172de857c60bbcc392f24a0a6d1fba42eb6190f82d8f01977f8b830e9db5ba0628eb50f2d6dcf0d0421c4b06e42adbd1d429c0c28281 SHA512 7ccb041271ed2688591942f46ab2d2c92d806efbd5209ff9aba77c6d5d3c1a1495fccbeb1718d914894b0b8d936438687e8f3cc22b7ab6625fb518321084ead3
diff --git a/dev-python/futures/futures-2.2.0.ebuild b/dev-python/futures/futures-2.2.0.ebuild
deleted file mode 100644
index a32041e878e7..000000000000
--- a/dev-python/futures/futures-2.2.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1
-
-DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
-HOMEPAGE="https://code.google.com/p/pythonfutures https://pypi.python.org/pypi/futures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # tests that fail under pypy
- # https://code.google.com/p/pythonfutures/issues/detail?id=27
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e 's:test_del_shutdown:_&:g' \
- -e 's:test_repr:_&:' -i test_futures.py || die
- fi
- "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( CHANGES )
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}