summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-16 18:12:58 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-16 19:38:11 -0600
commitfd36821cb47a1085d5e2fde2cc6fcd6dc2ce78ed (patch)
tree54b2dbd2dcba37ecb2a60dd2270e571184fba1fd /dev-python/futurist/futurist-1.6.0.ebuild
parentdev-python/oslo-middleware: 3.34.0 bup (diff)
downloadgentoo-fd36821cb47a1085d5e2fde2cc6fcd6dc2ce78ed.tar.gz
gentoo-fd36821cb47a1085d5e2fde2cc6fcd6dc2ce78ed.tar.bz2
gentoo-fd36821cb47a1085d5e2fde2cc6fcd6dc2ce78ed.zip
dev-python/futurist: 1.6.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/futurist/futurist-1.6.0.ebuild')
-rw-r--r--dev-python/futurist/futurist-1.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/futurist/futurist-1.6.0.ebuild b/dev-python/futurist/futurist-1.6.0.ebuild
new file mode 100644
index 000000000000..3882f6c3262e
--- /dev/null
+++ b/dev-python/futurist/futurist-1.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.python.org/pypi/futurist http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]"