summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYury Martynov <email@linxon.ru>2019-12-20 16:43:16 +0300
committerAaron Bauman <bman@gentoo.org>2019-12-22 21:24:47 -0500
commit3211b572fca57d640d10ca68142d4b6a0fe13188 (patch)
tree50399e25ee7ca4e9193024b919898c2f4e14e22a /dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild
parentnet-libs/accounts-qml: arm64 keyworded (bug #702290) (diff)
downloadgentoo-3211b572fca57d640d10ca68142d4b6a0fe13188.tar.gz
gentoo-3211b572fca57d640d10ca68142d4b6a0fe13188.tar.bz2
gentoo-3211b572fca57d640d10ca68142d4b6a0fe13188.zip
dev-python/fuzzywuzzy: bump to 0.17.0, add python3_{7,8} support
Closes: https://bugs.gentoo.org/703414 Closes: https://bugs.gentoo.org/656768 Closes: https://bugs.gentoo.org/639810 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Yury Martynov <email@linxon.ru> Closes: https://github.com/gentoo/gentoo/pull/14057 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild')
-rw-r--r--dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild b/dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild
new file mode 100644
index 000000000000..8ff35c557371
--- /dev/null
+++ b/dev-python/fuzzywuzzy/fuzzywuzzy-0.17.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fuzzy string matching in python"
+HOMEPAGE="https://github.com/seatgeek/fuzzywuzzy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pycodestyle[${PYTHON_USEDEP}] )"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test_fuzzywuzzy.py || die "tests failed under ${EPYTHON}"
+}