summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 08:17:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 10:52:25 +0200
commitbefe3f31d7f2bef85b5f81b1db4b5439cb1e8e2a (patch)
tree8a105f399cd298c87ddcbd9efb3490e7af6b3021 /dev-python/gast/gast-0.5.2.ebuild
parentdev-python/django: Bump to 3.2.6 (diff)
downloadgentoo-befe3f31d7f2bef85b5f81b1db4b5439cb1e8e2a.tar.gz
gentoo-befe3f31d7f2bef85b5f81b1db4b5439cb1e8e2a.tar.bz2
gentoo-befe3f31d7f2bef85b5f81b1db4b5439cb1e8e2a.zip
dev-python/gast: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gast/gast-0.5.2.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.2.ebuild b/dev-python/gast/gast-0.5.2.ebuild
new file mode 100644
index 000000000000..f25219967d31
--- /dev/null
+++ b/dev-python/gast/gast-0.5.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/astunparse[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest